WPFToolkit/MSBuild errors on Windows 7 64 bit.

Jul 15, 2009 at 1:40 PM

Hello,

I have project that normally builds and runs fine (on Vista 32bit). I just pulled a working copy on to a laptop recently installed with Windows 7 64bit, and although it will compile and runs from Visual Studio, I can't get it to compile from MSBuild. The project file is a standard .csproj file, and all service packs etc are installed.

The relevant part of the MSBuild output is:

ResolveAssemblyReferences:
  Primary reference "WPFToolkit, Version=3.5.40128.1, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL".
C:\Windows\Microsoft.NET\Framework64\v3.5\Microsoft.Common.targets : warning MSB3245: Could not resolve this reference. Could not locate the assembly "WPFToolkit, Version=3.5.40128.1, Culture=n
eutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL". Check to make sure the assembly exists on disk. If this reference is required by your code, you may get compilation errors.
          For SearchPath "{TargetFrameworkDirectory}".
          Considered "C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\WPFToolkit.exe", but it didn't exist.
          Considered "C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\WPFToolkit.dll", but it didn't exist.
          Considered "C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0\WPFToolkit.exe", but it didn't exist.
          Considered "C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0\WPFToolkit.dll", but it didn't exist.
          Considered "C:\Windows\Microsoft.NET\Framework64\v3.5\WPFToolkit.exe", but it didn't exist.
          Considered "C:\Windows\Microsoft.NET\Framework64\v3.5\WPFToolkit.dll", but it didn't exist.
          Considered "C:\Windows\Microsoft.NET\Framework64\v3.0\WPFToolkit.exe", but it didn't exist.
          Considered "C:\Windows\Microsoft.NET\Framework64\v3.0\WPFToolkit.dll", but it didn't exist.
          Considered "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\WPFToolkit.exe", but it didn't exist.
          Considered "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\WPFToolkit.dll", but it didn't exist.
          For SearchPath "{AssemblyFolders}".
          Considered "C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\WPFToolkit.exe", but it didn't exist.
          Considered "C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\WPFToolkit.dll", but it didn't exist.
          For SearchPath "{GAC}".
          Considered "WPFToolkit, Version=3.5.40128.1, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL", which was not found in the GAC.
          For SearchPath "{RawFileName}".
          Considered treating "WPFToolkit, Version=3.5.40128.1, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=MSIL" as a file name, but it didn't exist.
          For SearchPath "bin\Debug\".
          Considered "bin\Debug\WPFToolkit.exe", but it didn't exist.
          Considered "bin\Debug\WPFToolkit.dll", but it didn't exist.

The WPFToolkit installed into C:\Program Files (x86)\WPF Toolkit\v3.5.40619.1

Anyone know how to resolve this? Its a real pain not being able to automate the build.

Thanks,
Nick.