type 'dg:DataGrid' was not found

Aug 22, 2008 at 4:31 PM
I added a reference to WPFToolkit in my project and I also added xmlns:dg=http://schemas.microsoft.com/wpf/2008/toolkit  to the top of my Xaml.

Everything builds and runs just fine but the Xaml page designer will not load and references with the <dg:DataGrid> tag are underlined. When I hover over these I get the following message... "The type 'dg:DataGrid' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built."  What am I doing wrong here?

Another thing. I notice that my "http://" xml name spaces at the top of my Xaml's are not being underlined. Is this just a setting that can be changed in VS 2008?
Aug 26, 2008 at 2:15 AM
Edited Aug 26, 2008 at 4:33 PM
Hi, I've got the same problem when I create a new WFP project and add WPFToolkit.dll assembly to it ('using Microsoft.Windows.Controls' statement in .cs files is OK).
However, the example project from this article was opened correctly despite no marked difference in solutions, xaml code editor and designer worked as expected. I also guess there are only a few project setting options for sound mapping the namespaces.

PS: I use Visual Studio 2008 Team System SP1
Sep 13, 2008 at 7:08 PM
Hey folks,
     I ran into much the same problem when I got started.  The eventual solution was to either compile the project again, using a strong name, or as I did, to disassemble the provided dll using ildasm, generate a keypair using sn, and then to reassemble it using ilasm.  Straightforward directions for this can be found here. http://www.geekzilla.co.uk/ViewCE64BEF3-51A6-4F1C-90C9-6A76B015C9FB.htm I hope this helps.

Paul Allaire
Sep 14, 2008 at 5:03 PM
I have the same problem. App compile and run just fine, but I get error in dev mode. so I can't design.

Please explain in deitals how to solv it (with strong name?)

(Also using VS2008 .NET 3.5 SP1)