Can't install Client Profile Configuration Designer

Jan 26, 2010 at 7:08 AM

Hi,

I can't install Client Profile Configuration Designer (x86) on my computer, however I have installed .NET Framework 3.5 SP1.

I get an error log file on C:\Users\Tito\AppData\Local\Temp\ah_setup108957_install.log

 

 

[01/26/2010 07:59:20.223] Logging starts.
[01/26/2010 07:59:20.236] User culture: fr-FR, parent culture: fr, fallback culture: en-US.
[01/26/2010 07:59:20.236] Loading "C:\Users\LAPORT~1\AppData\Local\Temp\26012010075918\Microsoft.Net.Framework.3.5.SP1\product.xml".
[01/26/2010 07:59:20.243] Searching for msi.dll at "C:\Windows\system32\".
[01/26/2010 07:59:20.243] Examining file "C:\Windows\system32\msi.dll" for version info.
[01/26/2010 07:59:20.244] Could not detect fx1.0 Install.
[01/26/2010 07:59:20.244] Could not detect fx1.1 Install.
[01/26/2010 07:59:20.244] Detected fx2.0 Install, value = 1.
[01/26/2010 07:59:20.244] Detected fx2.0 Install, SP = 2.
[01/26/2010 07:59:20.244] Detected fx3.0 Install, value = 1.
[01/26/2010 07:59:20.244] Detected fx3.5 Install, value = 1.
[01/26/2010 07:59:20.248] ERROR: Unable to find Package.xml.
[01/26/2010 07:59:20.248] ERROR: Unable to load "Microsoft.Net.Framework.3.5.SP1\product.xml".
[01/26/2010 07:59:20.248] ERROR: Missing or invalid child element ProductRefs while parsing Deployment element.

[01/26/2010 07:59:20.223] Logging starts.

[01/26/2010 07:59:20.236] User culture: fr-FR, parent culture: fr, fallback culture: en-US.

[01/26/2010 07:59:20.236] Loading "C:\Users\Tito\AppData\Local\Temp\26012010075918\Microsoft.Net.Framework.3.5.SP1\product.xml".

[01/26/2010 07:59:20.243] Searching for msi.dll at "C:\Windows\system32\".

[01/26/2010 07:59:20.243] Examining file "C:\Windows\system32\msi.dll" for version info.

[01/26/2010 07:59:20.244] Could not detect fx1.0 Install.

[01/26/2010 07:59:20.244] Could not detect fx1.1 Install.

[01/26/2010 07:59:20.244] Detected fx2.0 Install, value = 1.

[01/26/2010 07:59:20.244] Detected fx2.0 Install, SP = 2.

[01/26/2010 07:59:20.244] Detected fx3.0 Install, value = 1.

[01/26/2010 07:59:20.244] Detected fx3.5 Install, value = 1.

[01/26/2010 07:59:20.248] ERROR: Unable to find Package.xml.

[01/26/2010 07:59:20.248] ERROR: Unable to load "Microsoft.Net.Framework.3.5.SP1\product.xml".

[01/26/2010 07:59:20.248] ERROR: Missing or invalid child element ProductRefs while parsing Deployment element.

 

 

Do you have an idea please ?

Thanks.

 

Feb 11, 2010 at 8:45 AM

Hi Thitony

1. Download the setup package of CPCD and save it locally.
2. At a command prompt, go to the location where you save the file.
3. Extract the package using <name of exe> /x:Extracted
4. Goto Extracted\Microsoft.Net.Client.ConfigurationDesigner and execute cp_designer_x86.exe