Cannot resolve dependency to assembly 'System.Windows, Version=2.0.5.0

Nov 15, 2017 at 3:52 PM
Edited Nov 23, 2017 at 4:54 PM
When I reference this library to a .NET4.5 WPF application, I get the error:

Unknown build error, 'Cannot resolve dependency to assembly 'System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' because it has not been preloaded. When using the ReflectionOnly APIs, dependent assemblies must be pre-loaded or loaded on demand through the ReflectionOnlyAssemblyResolve event.'

I also tried to convert the library to .NET4.5. It compiles, but I still get that compile type exception.

Have people been able to use this library with .NET4.0 or later?

Update: Copied the needed AutoCompleteBox files to a new project and the solution compiles and runs when I add that new library to my project. Progress.

Now the issue is each AutoCompleteBox shows the exception:

The specified value cannot be assigned to the collection. The following type was expected: "UIElement".

And all the dependency properties show something like:

The member "Text" is not recognized or is not accessible.

Have people been able to use the AutoCompleteBox in .NET4.0 or later?