Datagrid excel copy Bug , data with € symbol

Jul 23, 2010 at 1:59 PM

Hi All,


I have a strange problem while copying data with € symbol from wpf datagrid to excel.

I have 5 columns where I show some financial data corresponding to certain conditions. Data is shown with euro(€) symbol.

All data is shown in correct format in the datagrid, but when i trry to copy the data from datagrid to excel, few data from last row last few columns are missing.

Example of data copes to excel:

Euro (EUR)    1.360,86 €    1.457,64 €    66.673,81 €    60.986,62 €    11.041,19 €
US Dollar (USD)    1.129,02 €    5.951,20 €    73.583,31 €    61.549,90 €    7.049,14 €
British Pound (GBP)    1.796,65 €    1.134,05 €    11.552,33 €    9.769,56 €    1.169,24 €
Swiss Franc (CHF)    1.783,13 €    2.583,73 €    3.542,02 €    2.539,14 €    360,38 €
Australian Dollar (AUD)    1.196,79 €    3.307,68 €    4.800,34 €    4.896,10 €    596,04 €
Canadian Dollar (CAD)    1.626,58 €    2.154,89 €    3.048,50 €    2.869,03 €    347,05 €
Japanese Yen (JPY)    100,76 €    877,44 €    1.403,33 €    2.609,02 €    883,78 €
Swedish Krona (SEK)    161,57 €    478,56 €    875,26 €    952,18 €    144,81 €
Danish Krone (DKK)    182,30 €    543,56 €    652,59 €    1.806,91 €    69,30 €
Brazilian Real (BRL)    181,76 €    884,83 €    301,75 €    528,66 €    141,63 €
Others    1.733,24 €    1.293,80 €    (data missing)        

Datagrid copies all data properly to excel when '$' symbol is used, issue seems only with € symbol.


Do anyone know how can I fix this issue.