MVVM Toolkit not installing properly?

Apr 21, 2010 at 7:18 PM

Hi there,

I'd like to try the WPF MVVM Toolkit, but I am not sure about a couple of things:

1) the only download link I have found is the following: WPF Model-View-ViewModel Toolkit 0.1 in WPF Futures, dated May 2009. Is that right? Is there a more recent release?

2) When I try to install the WPFModelViewTemplate.msi, which should install the needed templates into Visual Studio, nothing happens: I start up Visual Studio and I cannot find any new project or solution type that use the WPF MVVM Toolkit.... I am using VS2008. Any suggestion that might point me in the right direction?

Thanks in advance,


Apr 23, 2010 at 5:17 PM

Hello everybody,

Sorry for the late reply on this.

I have found the answer to my questions, and I am posting it back here for future reference:

1) yes, I assume it is. I've looked around for a while looking for a more recent version, but I couldnt find it. I guess my confusion was due to the fact that there was a WPF toolkit version dated Feb 2010, and I thought the MVVM was kind of included in it. But it is not.

2) There is nothing wrong with the MVVM or its setup... or at least nothing wrong when Visual Studio is set up in English. Mine was not. For this reason it was looking for the available project templates in the 1040 folder, the one corresponding to Italian, whereas the templates were installed into the 1033 folder, which is used by the English version. So, I forced my VS to English, and that did the trick.

I hope this will help someone out there.



May 27, 2010 at 7:25 PM

Hi all !


Is there a way to install the template in our language folder ? I don't have the possibility to change the language of VS2008 but I would like to use these template.